Odd Bug

Oct 26, 2010 at 2:10 AM
Edited Oct 26, 2010 at 2:19 AM

Running Windows 7 64-bit

I first got this in version 1.2 but it continued in version 1.3, so I decided to ask about it.

When I start the program, and then either click on the masteries tab or the masteries button. 



This is what happens if I click the About tab after that



Sort of looks like its just stacking the tabs on top of each other. Also, I believe there are supposed to be like save, load, etc. options on the left side of the masteries tab, but they've only ever showed up once, and went away when I switched tabs and then back.

Any ideas?

Before I had to leave I had time to try it with Aero turned off; didn't help.

Oct 26, 2010 at 2:05 PM

I'm afraid this is an issue on your PC since we are using default .Net components. Redrawing should work just fine on them and I have no idea what could cause this issue.

What you could try is put another window on top of it (like calculator) and see if the parts below it get redrawn properly. Otherwise I'm afraid I can't help you.

Oct 26, 2010 at 3:15 PM
Edited Oct 26, 2010 at 4:17 PM

I couldn't get that calculator trick to work, but what you said made me redownload the .NET installer and repair to defaults, which seems to have worked beatifully.

Cheers mate and well done to both of you on the app.



Now that I've used it more thoroughly, it seems as if the problem lies within AutoLoL again. Perhaps its something I have mixing with it. Anyway, now when I open it, if I hit the masteries tab after any length of time, it does the exact same thing as it used to with absolutely no .NET changes to my computer since I repaired it to defaults. However, if I let it sit for 10 seconds or so, then i can get to the masteries tab by using the button next to the resolution on the start tab. However, changing to a different tab at any point after that messes it up. The time delay seems weird, but I can consistently reproduce it. It's certainly usable in its current state, if a little inconvenient, so I just thought I'd let you know.

Oct 26, 2010 at 4:23 PM
Edited Oct 26, 2010 at 4:31 PM

I know you said that you don't know what could be causing the issue but it seems broken again in 1.4, even my little time workaround.

I've gotten 1.4 to work a few times but it's very hit and miss. sometimes if I use the launch LoL button and then the masteries button, it will get there. Once when I just moved the screen around before clicking it. I'm at a loss. The text even wrote on top, though slightly skewed, of itself when I saved my LoL directory information, etc.

Oct 26, 2010 at 4:31 PM

Reinstalling .net didn't work either this time?

Perhaps reinstalling your video drivers could fix the issue?

Oct 26, 2010 at 4:38 PM

I'm in the process of installing .NET again atm, and I'll check for a driver update as well. Not sure if this gives you any more information, but when I could get to the masteries tab, sometimes it didn't seem to detect clicks, but removing a mastery point or starting a new tree would seem to make it detect them for some reason. 

Oct 26, 2010 at 4:52 PM

A complete reinstall of .NET seems to have fixed it again, at least for now. Last time I had to restart my computer for it to mess up, but I guess I'll be back if I have more troubles.